Tag Archives: injector

Weekend stuff

The boys and I did some work on the truck. A rainstorm on Friday made it clear I hadn’t gotten all the degreaser out of the cab or dashboard, as there were streaks everywhere, so we got a bucket and rags and scrubbed everything. The floor mats now look a lot better.

I removed the channel cover on driver and passenger side, and discovered that on the driver’s side, there was dirt packed solid into the channel. I scraped and vacuumed out probably several pounds of dirt.

We washed the truck, which made it look somewhat better.

And, I tightened most of the CAC boot clamps. Every one seemed looser than it should have been. I can’t remember what the torque spec is, nor do I think I have a small enough torque wrench. But, having tightened the clamps, I noticed an immediate improvement in power. The truck is definitely boosting significantly harder. My boost gauge says I got it to about 20.5 psi going up Gibson at WOT, which is a lot better than it was doing (previously about 15-16 psi).

A temporary fix until I can replace the CAC boots, compressor wheel and rebuild the turbo. But I’m amazed at how much it woke the truck up. I think this engine’s got potential, especially after I replace the bad injector (but, then again, it seems to be running better and better. I think the Hot Shot Secret is doing its job).

Also, I pulled the trailer for the first time yesterday, with the KX 250 and the PW80 on it. It’s like it’s not even there.

Advertisements

Codes

Pulled the codes from the ECU this morning just before I went in to work.

P0275 – Cylinder 5 Contribution/Balance Fault
(possible issue with injector #5, which is the third injector from the front of the engine, passenger side)

I need to do a “buzz test” on the injectors — not sure how — to verify that it is not an electrical problem with the #5 injector. Rumor has it that “Car Gauge Pro”, an Android app, can do it, but there are reports that it can screw up your ECU, as well.

bismic says in this thread to check the following to diagnose a single bad injector:

“1. wiring to injector
2. injector hold down bolt
3. injector copper gasket (is it present and in good shape)
4. faulty injector

If you suspect a faulty injector, swap it with another one and see if the code follows it.”

P0603 – Internal Control Module Keep Alive Memory Error
(this was set when I disconnected the batteries for an hour or so last week — just need to clear it)

P0678 – Cylinder 8 Glow Plug Circuit Fault
(bad glow plug? cyl. 8 is the rearmost cylinder on the driver side)

P0683 – Glow Plug Module Control To ECM Communication Circuit Fault
(possible gpcm issue)

I am grouping these two together, because they often appear together. According to this, the procedure is to test the #8 glow plug’s resistance, which should be less than 1 ohm. If the plug tests bad, replace the plug. If the plug tests good, replace the glow plug control module.

P1000 – On Board Diagnostic System Readiness Test Not Complete
(same issue as P0603. Can just clear this code)

P132B – Turbocharger Boost Control ‘A’ Performance
(basically, turbo is not achieving desired boost levels)

Currently the truck is making about 15 psi boost at WOT. It should be able to make nearly twice that.

This could be caused by several things. I’m fairly certain my hot side CAC boots are leaking oil, which means they’re also leaking boost. Also, I know the turbo compressor blades are chewed up, which is guaranteed to cause the turbo to not make as much boost as it should. The turbo could also need a good cleaning, or there could be other problems.

Solution is to first replace the CAC boots and see how much that improves matters. Then replace the compressor wheel or the whole turbo.